More threads by JoyHawkins

JoyHawkins

Administrator
Local Search Expert
LocalU Faculty
Joined
Aug 23, 2014
Messages
4,768
Reaction score
2,433
There appears to be an issue right now with businesses not being able to respond to questions on their listings as the owner. When answering a question posted on a Google My Business listing, the response shows up as your name instead of from the owner.

I've seen several reports of this on the GMB forum and am able to replicate it myself. I've alerted Google about the issue so hopefully it's fixed soon.

4254

1561232550222.png
 

Adentity

Member
Joined
Jun 19, 2019
Messages
9
Reaction score
6
Hello everyone!

I still have this problem. Someone can respond the question as a business owner?

Thank you in advance
 

JoyHawkins

Administrator
Local Search Expert
LocalU Faculty
Joined
Aug 23, 2014
Messages
4,768
Reaction score
2,433
I sent it to Google but haven't heard back that it's fixed yet.
 

JoyHawkins

Administrator
Local Search Expert
LocalU Faculty
Joined
Aug 23, 2014
Messages
4,768
Reaction score
2,433
Interesting, mine still say my name.
 

pony

Member
Joined
Jun 26, 2019
Messages
124
Reaction score
85
Barry, your screenshot is of review responses. This bug is related to the Google Q&A feature.
+1 here, you guys are looking at two different areas. Working correctly in review responses (Barry's screenshot) but not working in Q&A responses.
 

mkingsle

Member
Joined
Feb 11, 2019
Messages
5
Reaction score
3
Thanks Joy:

I was beating my head on Friday because of this very issue.

Glad to know I am not alone.

Hopefully this gets fixed so it's a better user experience knowing when q&a come from the business owner.

Different related topic, but I noticed that a question I posted received a response almost instantly from a Google local guide. It wasn't even close in the correct answer. Wish there was a way to police that better as a business owner in order to make sure answers aren't incorrect.
 

JoyHawkins

Administrator
Local Search Expert
LocalU Faculty
Joined
Aug 23, 2014
Messages
4,768
Reaction score
2,433
You should be able to flag it if it's an incorrect answer.
 

Jen Currier

Member
Joined
Sep 18, 2018
Messages
34
Reaction score
29
I am trying to respond to a Question posted on Google on behalf of a client, I had Manager access and was prompted to post under my personal account rather than as the business. My client temporary changed my privileges to Owner and I am still only able to respond as Local Guide through my personal account. I am thinking that Answers need to come from the Primary Owner in order to be published as the "Company" responding rather than a person, but I can't seem to find any resources to support this. Am I doing something wrong? To access the Questions I am logging into my GMB Dashboard > opening the listing from View on Search > clicking on See All Questions > Answer.

Please advise...
 

Jen Currier

Member
Joined
Sep 18, 2018
Messages
34
Reaction score
29
I posted a new thread yesterday not realizing this was already being addressed, so I wanted to move my comments here rather. Initially I thought I was doing something wrong or thought that perhaps it had to be the Primary Owner only who could post as the Business. Then @Claire Carlile pointed me in this direction (thank you!) and now I know it is a bug. With that said I just wanted to confirm this is still happening. Any chance you have received an update from Google regarding this @JoyHawkins ?
 

JoyHawkins

Administrator
Local Search Expert
LocalU Faculty
Joined
Aug 23, 2014
Messages
4,768
Reaction score
2,433
Definitely still happening. No fix yet. Ben Fisher, however, gave me a super awesome tip that you can still respond as the owner using the Google Maps app on your phone.
 

Aly Kurtz

Member
Joined
Dec 11, 2018
Messages
15
Reaction score
8
Used to be able to post questions and answers to questions on the KP as the "business owner". Seems like this is no longer an option. Has anyone else noticed this? As an agency we are set up as an owner in the GMB profiles for our clients. Those permissions used to allow us to create and answer questions as the business owner. The screenshot below is of me trying to post a question on the KP for one of our clients. In this account I am acutally the primary owner, so I don't see why it wants to list me as "A Google User".

Any thoughts?
1563548203955.png
 

Login / Register

Already a member?   LOG IN
Not a member yet?   REGISTER

LocalU Event

  Promoted Posts

New advertising option: A review of your product or service posted by a Sterling Sky employee. This will also be shared on the Sterling Sky & LSF Twitter accounts, our Facebook group, LinkedIn, and both newsletters. More...
Google Product Exert


QRCode

QR Code
Top Bottom