eshad

Member
Joined
Aug 27, 2019
Messages
30
Reaction score
8
Hi there,

Is anybody else noticing that logos are being removed from GMB profiles?
I have 15 GMB profiles in my account and over the last week all have been removed.

When I go into images within each accounts dashboard the logos are still visible. I have removed and re uploaded to the listings but still it doesn't display.
On the home page of each listing it also states the listing is not complete and that a logo needs to be added.

Be interested to hear if anybody else is having this issue.

Edward
 

Butch Flarida

Member
Joined
Nov 11, 2020
Messages
4
Reaction score
1
Hi Edward,

Yes 15 of our clients have the same issue. I have also seen insight data not available for the past few days, wondering if anyone else has had this issue?
 

DangGood

Member
Joined
Nov 19, 2020
Messages
14
Reaction score
4
Just an FYI, my logos went missing too but are back today. But now all my other photos say “no views” despite previously having 1000s... So you might want check that too. I guess eventually that’ll get corrected as well. Oh dear :)
 

Theo1313

Member
Joined
Sep 30, 2019
Messages
21
Solutions
1
Reaction score
11
My listing's logo is there but on the home page of GMB it keeps displaying the message "add a logo to your listing" -- it also says my listing is only 85% complete -- which I know is not true.
 

georgenenni

Member
Joined
Aug 26, 2020
Messages
28
Reaction score
42
My listing's logo is there but on the home page of GMB it keeps displaying the message "add a logo to your listing" -- it also says my listing is only 85% complete -- which I know is not true.
Same situation for a large % of our auto dealer customers. Were you able to find a fix? thank you!
 

Theo1313

Member
Joined
Sep 30, 2019
Messages
21
Solutions
1
Reaction score
11
My listing's logo is there but on the home page of GMB it keeps displaying the message "add a logo to your listing" -- it also says my listing is only 85% complete -- which I know is not true.
Same situation for a large % of our auto dealer customers. Were you able to find a fix? thank you!
I re-uploaded our logo but it still gives the message.

Capture.PNG
 

k.ivanova

Member
Joined
Dec 8, 2015
Messages
17
Reaction score
9
Joining you here to share that the majority of our accommodation businesses have the logo issue as well - although it is added in GMB photos to the dedicated section, it is not being detected even after reupload and the percentage falls to 65%.
The logos are not visible on the live listing for months now, also resets of imagery assets have been an issue during the past few months.
Google are on to something for sure!
 

raellovepie

Member
Joined
Jul 15, 2019
Messages
108
Solutions
1
Reaction score
122
Solution

Login / Register

Already a member?   LOG IN
Not a member yet?   REGISTER

LocalU

LocalU Nov2021

Most UpVoted Answers

  Promoted Posts

New advertising option: A review of your product or service posted by a Sterling Sky employee. This will also be shared on the Sterling Sky & LSF Twitter accounts, our Facebook group, LinkedIn, and both newsletters. More...
Google Product Exert


Top Bottom