More threads by Laustin1878

Sep 27, 2012
Reaction score
Trying to hone in on another issue, I did a search for a business and noticed that the business name was missing from the business in the list to the left. The address was only displayed. The pins on the map showed the business name when you hover over it. What gives? I tried a few queries and the same thing. Could it be a glitch?

I also tried clicking to go to the listing and it was G+ Local and everything displayed fine, it was just an issue when viewing the list.
Hard to say what's going on without a visual. Can you provide screenshots of what you are talking about?
I tried getting a screen shot to embed and I was unable to get it to display. It has since corrected itself so it must have been a glitch somewhere. I checked it over a few hours and finally decided to post as I have never noticed that before.

Basically, in the list view of businesses on the map, instead of the company name displaying, it only displayed the address so the address was the link to the profile. It's working now so onto the next task....haha
It might have been Google's habit of sometimes showing title tags instead of the business names used for Google+ listings. If the address was in your title tag, I think that would explain it. If the address wasn't in there, then I'd agree that it was probably just a glitch
Phil, I have seen that before as well but only for one listing and it was not a merged Google+ page yet, just Google Places. I actually questioned it because I never saw that before and wanted to affirm that Google treated it as a trust match. It appeared that when the title tag was displaying for the map result, Google identified that the website and Places page were matched. I thought this was a positive thing as G knew the two were the same business. The listing in the SERP's had the title tag of the homepage as the map listing and also had the 'A' pin next to the search result.

I only saw the address displaying where the title was supposed to be in the maps listings today. It was like that for several hours for numerous queries. I checked before posting earlier and saw that it corrected itself so it appears to have been a glitch of some sort. On the website, the address does not appear in any of the title tags for any of the pages.
Interesting. Guess it's the mystery du jour.

Login / Register

Already a member?   LOG IN
Not a member yet?   REGISTER

LocalU Event


  Promoted Posts

New advertising option: A review of your product or service posted by a Sterling Sky employee. This will also be shared on the Sterling Sky & LSF Twitter accounts, our Facebook group, LinkedIn, and both newsletters. More...
Top Bottom