More threads by djbaxter

djbaxter

Administrator
Joined
Jun 28, 2012
Messages
3,778
Solutions
2
Reaction score
1,877
Forum upgraded this morning (2.2.11 security plus other fixes). Reply to this thread if you notice anything that doesn't seem to be working as expected. :)
 
Still no dice, the source code shows that there is a double <li><a href= in the code that needs to be removed.

Screenshot-2022-10-11-113437.jpg
 
Can you try now? It's working for me now on Chrome and Firefox and Edge.
 
I have cleared my cache, completed a hard refresh, and tried multiple browsers, the incorrect code is still there. Is it a server caching issue?
 
Just for extra info, I'm seeing it too.

The Localu.org link in the top right header is returning a broken link due to the double "a href"
 
What exactly happens when you click on the link in the navigation bar?
 
@Conor Treacy @keyserholiday

Please try again now. The navigation bar link should be LocalU Technical Information and Help

Hi DJ, it looks like the link associated with the "LocalU.org" upper navigation is still not working. Also, it appears to be a slightly different issue than what Jason and Conor initially reported. After looking at it more closely, I navigated to several different pages on the forum. The "LocalU.org" link appears to be dynamically changing depending on page the user is currently navigating, it is not static. For example if you go to "Forum Rules", and then hover over "LocalU.org" link, you'll notice that the link becomes the current page's url with the extraneous "<li><a href=" appended to the end of the link.

Hope this is helpful. Otherwise, there were a couple of glitches that existed before the upgrade that now appear to be fixed. Thanks!
 
I iust don't understand it. I'm not able to repliczgte it here. The link goes to the correct page from anywhere on the forum in each of the three major browsers for me.

The only thing I can think of is browser cache or ISP cache for mobile browsers. A previous verskion of the link I tried could have produced a different result from different pages but the current oned has the full URL as posted above and this works every time for me. :(
 
Hey DJ, just wondering, have you tried it in a private/incognito window? I have tried it on my home desktop, personal laptop, office desktop and each shows a malformed link for LocalU. Tried Chrome, FF, Edge, Safari, Windows, MacOS. Same result whether I'm signed into the forum or not.
 
Loaded the forums here using a proxy service and still get the broken link too;

Hidester Proxy - Fast & Free Anonymous Web Proxy (for example)

This is the code from the section;

Code:
<ul class="hScroller-scroll is-calculated" style="margin-bottom: -47px;">

                            <li><a href="https://www.sterlingsky.ca/">SterlingSky.ca</a></li>

<li><a href="<li><a href=" https:="" localu.org="" "="">LocalU.org</a></li>

<li><a href="/showthread.php?44564-Advertising-amp-Sponsorship-at-the-Local-Search-Forum">Advertising</a></li>

<li><a href="/index.php?misc/contact/">Contact Us</a></li>

                        </ul>
 
I am still not able to replicate the problem in Google Chrome. Looged in, not logged in. Icognito/private tab, regular tab. Vrome, Edge, Firefox. It always goes to the correct link for me.

I'm baffled.

Just to clarify, we are talking about the link in the navigation bar which links to the LocalU forums which are subforums of the LSF, correct?

localu=forums.jpg



 
Oh okay.... I've been working on the wrong link. The top link is now fixed.

YAY!!
Working for me when I visit the site and I"m not logged in, but when I'm logged in, I still get the old link.
Tried logging in, in incognito, and cleared the browser cache etc - so there must still be a cache happening somewhere. Only showing the error when I'm logged in as a user.
 

Login / Register

Already a member?   LOG IN
Not a member yet?   REGISTER

LocalU Event

LocalU - Level Up Your Content Marketing Game with AI

  Promoted Posts

New advertising option: A review of your product or service posted by a Sterling Sky employee. This will also be shared on the Sterling Sky & LSF Twitter accounts, our Facebook group, LinkedIn, and both newsletters. More...
Top Bottom