KieranThomas

Member
Joined
Sep 30, 2021
Messages
6
Reaction score
2
Hi all,

Firstly, this is my 1st post in the forum so ... hi!
Also, I hope I'm adding this to the correct area so please accept my apologies if it would be better located in a different section.

Anyway, onto the reason for this post...

A few months ago (May 2021) I was working on a GMB listing for a client and I noticed that the "Call" button seemed to be missing.
Not only that, but weirdly at the same time, the phone number would only display when the call button was NOT displayed. If the call button was displayed, the phone number would NOT be.

(Note: The missing phone number issue has since been resolved. and so I'm not sure if it was a bug, or if they were A/B testing to see if it encouraged usage of the Call button.)

After some investigation, I noticed that the Call button doesn't display under certain conditions when viewed in desktop view.
  1. Google Chrome: logged out of Google account = Call button not visible
  2. Google Chrome: logged into Google account = Call button visible
  3. Firefox: Logged in = Call button not visible
  4. Firefox: Logged out = Call button not visible
  5. Microsoft Edge = Call button not visible
  6. Microsoft Edge = Call button not visible
I assumed it must be a local environment issue initially, so I tried clearing my cache. Same results
I also disabled all of my plugins, etc to see if there was a conflict. Same results

As a result, I flagged it with the GMB support team and they said it was working fine for them, so I went back to trying other things.

To rule out potential issues with plugins, permissions, etc I asked various colleagues to try. All use different computers, have different accounts, have predominantly different setups as none of them work in SEO (i.e. design teams, etc). Same results.

As we're all on the same network, I tried my computers at home. Now, these all have totally different Google Accounts as they're my personal machines and therefore use my personal Google Accounts. Not only that, but one is so old it's running,... wait for it.... Windows Vista! So I tried it on that. It's a PC I've not used in years so still has Internet Explorer installed. Same issue.

So I went back to the GMB team again, and each time they insisted it was working fine their end. However, each time I asked if they could provide some screenshots to help me with debugging further they refused.

Their advice.... Contact the other browser manufactures and ask them to fix the issue their end. I kid you not!

So I have a few questions:
  1. Has anyone else experienced this issue?
  2. Is anyone else able to replicate each of the scenarios above, or is it just me?
  3. If it's working for others - Does anyone know what might be preventing from working?
  4. If no one can get it working in the above scenarios (I'll be glad it's not just me!)... does anyone know why Google have suggested it's up to the browser manufacturers to resolve the issue their end? Seems a little odd.
  5. Can anyone think of a logical reason for the call button to not display when logged out? I understand that it routes some calls via Google's systems when going via Chrome, but I can't understand why they haven't set it to degrade gracefully to use just tel: when that's not available. Seems like a poor user experience to remove a function purely for that reason.
Thanks,
Kieran

missing-gmb-call-button.jpg
 

ElizabethRule

Administrator
Local Search Expert
LocalU Faculty
Joined
Oct 15, 2021
Messages
16
Reaction score
26
Hi Kieran,

Welcome to the forum!

Since you are only seeing the Call button when logged into your account on Google chrome, I am hesitant to suggest it could be a Google Live Experiment, though it could be possible. In this Google search help thread, there are other users experiencing the same type of issue, yet it seems most of the time the Call button is NOT visible when they are logged in, and visible when they are not.

I am also unable to replicate this issue, the call button is appearing for me when I am signed in as well as in incognito.

As pointed out int the bottom of the thread I linked to, the best option to send feedback to Google on issues like this is to use the "Send Feedback" link at the bottom of the results page (desktop/laptop), or the in-app "Send Feedback" feature (mobile/tablet).

I am glad the issue is fixed though per your note :)
 

Login / Register

Already a member?   LOG IN
Not a member yet?   REGISTER

LocalU

LocalU Nov2021

Newest Posts

Most UpVoted Answers

Trending: Most Viewed

  Promoted Posts

New advertising option: A review of your product or service posted by a Sterling Sky employee. This will also be shared on the Sterling Sky & LSF Twitter accounts, our Facebook group, LinkedIn, and both newsletters. More...
Google Product Exert


Top Bottom