mandeepb

Member
Joined
Apr 19, 2021
Messages
14
Reaction score
1
Hi,

I have been doing a local citation audit for our local client using Bright Local. There's been an issue since I started doing it. I have updated many citations manually, which I had created last year. But the Bright Local tool is still showing issues with the NAP. Attached screen shot. Any comment would be grateful

bb.PNG
 
Joined
Apr 27, 2021
Messages
2
Reaction score
0
Hi @mandeepb,

Kristian from BrightLocal here 👋

Sorry to hear you've run into an issue with your audit. I have a good idea on how to resolve it but I'd need to check the specific report to be sure.

One of our Customer Success team has a good idea of which report this screengrab is from.

If it's ok with you, they're going to reach out to you directly to walk you through the solution.

Thanks,
KB
 

mandeepb

Member
Joined
Apr 19, 2021
Messages
14
Reaction score
1
Hi @mandeepb,

Kristian from BrightLocal here 👋

Sorry to hear you've run into an issue with your audit. I have a good idea on how to resolve it but I'd need to check the specific report to be sure.

One of our Customer Success team has a good idea of which report this screengrab is from.

If it's ok with you, they're going to reach out to you directly to walk you through the solution.

Thanks,
KB
Hi @Kristian Bannister

thanks for the response. Yeah, that would be great if you can help me out. How would you contact me?
 

Login / Register

Already a member?   LOG IN
Not a member yet?   REGISTER

Most UpVoted Answers

LocalU

  Promoted Posts

New advertising option: A review of your product or service posted by a Sterling Sky employee. This will also be shared on the Sterling Sky & LSF Twitter accounts, our Facebook group, LinkedIn, and both newsletters. More...
Google Product Exert


Top Bottom