j_holtslander

Member
Joined
Feb 5, 2019
Messages
133
Reaction score
110
I tried creating a place through the Google Maps app for a business that I'm not an owner or representative of, using known, verifiable, public information. (Name, address, phone, and located within.) Within seconds of the submission Google had disapproved the addition. (Screenshot attached)

Anyone know why this might be? Would this be an indicator that the place existed on Maps once before but was removed? And this is some kind of re-add prevention?

IMG_5708.jpeg
 

Phil Rozek

Local Search Expert
Joined
Jul 26, 2012
Messages
1,912
Solutions
14
Reaction score
1,494
@j_holtslander, I've never run into problems when adding a place to the map publicly (not that I do it often), so I don't know off-hand.

1. Are there other nearby locations of the same business?

2. Did you check before and/or after to see whether that location of the business was already listed? (I know you asked "Would this be an indicator that the place existed on Maps once before but was removed?" The "Still in business" part of the edit history makes me suspect the same thing.)

3. What happens if you try not including some of the business's info (so that it's a partial submission), or adding a different business, or editing in a different Google account?
 

j_holtslander

Member
Joined
Feb 5, 2019
Messages
133
Reaction score
110
Without the phone number this time it sat as “Pending” for a few minutes before changing to “Not applied”
 

Phil Rozek

Local Search Expert
Joined
Jul 26, 2012
Messages
1,912
Solutions
14
Reaction score
1,494
Interesting. Point #3 contained a few different things to try, in the way of troubleshooting. Though perhaps you've tried them already.
 

j_holtslander

Member
Joined
Feb 5, 2019
Messages
133
Reaction score
110
3. (Cont.) Different business (or other maps functions) No problem.
Different Google account, same result.
 

Login / Register

Already a member?   LOG IN
Not a member yet?   REGISTER

Most UpVoted Answers

LocalU Podcasts

  Promoted Posts

New advertising option: A review of your product or service posted by a Sterling Sky employee. This will also be shared on the Sterling Sky & LSF Twitter accounts, our Facebook group, LinkedIn, and both newsletters. More...
Google Product Exert


Top Bottom