More threads by Penni

Penni

Member
Joined
Mar 8, 2022
Messages
3
Reaction score
0
Is anyone else having any issues adding a photo or cover photo in the photos tab of GBP. I have tried multiple times since about last Thursday in multiples different listings and I keep getting the same error. I have tried adding to the dashboard and straight onto the listing. I think most if not all files I used were jpg.
1657129299468.png
 

Conor Treacy

Member
Joined
Feb 25, 2014
Messages
420
Reaction score
320
Hi @Penni
We had a client contact us on this today. No matter what they uploaded, it was not accepted.

Here's part of the email I sent to them and this seemed to resolve things;

I made the cover logo 1024x576
I created a LOGO at 250x250
I created a POST with your image and some sales text
I uploaded an "exterior" shot at 720x720
I changed the image for the "team" to be "At Work"

At this time, each of those images are now showing online when I check in Google Search.

So the "exterior" and "team" were also at 720x720. This was a brand new GMB setup that was only created early in the morning. Give that a shot and see if things go through. All images were JPG and were under 300kb. Google's guidelines say under 10MB JPG or PNG. I used JPG for this client. Once I uploaded the images (around 4 pm Central June 6th) the images were showing in Search and KB a few minutes later when I searched for their name.
 

Penni

Member
Joined
Mar 8, 2022
Messages
3
Reaction score
0
Hi @Penni
We had a client contact us on this today. No matter what they uploaded, it was not accepted.

Here's part of the email I sent to them and this seemed to resolve things;

I made the cover logo 1024x576
I created a LOGO at 250x250
I created a POST with your image and some sales text
I uploaded an "exterior" shot at 720x720
I changed the image for the "team" to be "At Work"

At this time, each of those images are now showing online when I check in Google Search.

So the "exterior" and "team" were also at 720x720. This was a brand new GMB setup that was only created early in the morning. Give that a shot and see if things go through. All images were JPG and were under 300kb. Google's guidelines say under 10MB JPG or PNG. I used JPG for this client. Once I uploaded the images (around 4 pm Central June 6th) the images were showing in Search and KB a few minutes later when I searched for their name.

Thank you! That didn't work. I had my colleague try and add the photos normally through the same account and it worked fine. So I guess it must be something with my computer. This just started happening in the last week though, so issues prior to that.
 

Conor Treacy

Member
Joined
Feb 25, 2014
Messages
420
Reaction score
320
@Penni I wonder if maybe there was a browser issue. You may want to check your browser against what worked with the other person and see if they're different. Maybe try using a GUEST mode on Chrome and then logging in to see if that helps, or using an alternate like FF or IE to see if that works. Odd to have it working for one and not for another.
 

Penni

Member
Joined
Mar 8, 2022
Messages
3
Reaction score
0
@Penni I wonder if maybe there was a browser issue. You may want to check your browser against what worked with the other person and see if they're different. Maybe try using a GUEST mode on Chrome and then logging in to see if that helps, or using an alternate like FF or IE to see if that works. Odd to have it working for one and not for another.

She started having the same problem, so we figured it out with the simplest of solutions. We cleared our browser history and now it's working again :) Thanks for your help!
 

Login / Register

Already a member?   LOG IN
Not a member yet?   REGISTER

LocalU Event

  Promoted Posts

New advertising option: A review of your product or service posted by a Sterling Sky employee. This will also be shared on the Sterling Sky & LSF Twitter accounts, our Facebook group, LinkedIn, and both newsletters. More...
Google Product Exert


QRCode

QR Code
Top Bottom