More threads by Chris Ratchford

Chris Ratchford

0
Administrator
Joined
Jul 18, 2012
Messages
312
Solutions
1
Reaction score
85
My client's WP site, which I originally developed about 4 years ago, is up for a new site. I'm reviewing the GA data to see which pages are of low value.

In Analytics, when I go to BEHAVIOR > SITE CONTENT > ALL PAGES, I see these URLs:
2019-07-31_13-59-12.png


When I click on any of those pages, they are all 404 because this is a WordPress site and I've never used .html extensions. I checked the Permalink Settings in WP, and they're the standard structure I always use: domain.com/%category%/%postname%/.

What could be causing this issue?
 
I came across this issue on a site a week or two ago. Go into the Google Analytics Admin > View > View Settings and get rid of the Default Page. I'm betting it's set to index.html. Those numbers you're seeing aren't really for 404s. They are for the URL's minus the index.html suffix.
 
My client's WP site, which I originally developed about 4 years ago, is up for a new site. I'm reviewing the GA data to see which pages are of low value.

In Analytics, when I go to BEHAVIOR > SITE CONTENT > ALL PAGES, I see these URLs:
2019-07-31_13-59-12.png


When I click on any of those pages, they are all 404 because this is a WordPress site and I've never used .html extensions. I checked the Permalink Settings in WP, and they're the standard structure I always use: domain.com/%category%/%postname%/.

What could be causing this issue?

I don’t have a lot of experience with this but something similar happened to me when I migrated a WP site to Liquid Web. For some reason after moving the site, all the pages loaded with /index.html appended to the end of them. Have you moved hosts or anything like that recently?
 
Was this a html site migration or did they use the domain in the past? It might be worth checking wayback machine to see if the domain was ever previously used (also check Whois "created date").

WP pages shouldn't have .html in the URLs because WP is php based. I would expect to see index.php not index.html.
 
I came across this issue on a site a week or two ago. Go into the Google Analytics Admin > View > View Settings and get rid of the Default Page. I'm betting it's set to index.html. Those numbers you're seeing aren't really for 404s. They are for the URL's minus the index.html suffix.
Wow- that's EXACTLY what I found! Thanks!
 
@Chris Ratchford Cool! That should fix it. Happy to help!

@Eric Rohrback You're correct that WP URLs usually don't have this, but it can be appended under Settings > Reading > Custom Structure. I thought I'd mention it in case anyone comes across this thread in the future.
 

Login / Register

Already a member?   LOG IN
Not a member yet?   REGISTER

LocalU Event

LocalU Webinar Feb 27th 2024 - Unlock Your GBP and Performance Data Potential

  Promoted Posts

New advertising option: A review of your product or service posted by a Sterling Sky employee. This will also be shared on the Sterling Sky & LSF Twitter accounts, our Facebook group, LinkedIn, and both newsletters. More...
Top Bottom