More threads by Wirenut


Oct 26, 2019
Reaction score
Google Search Console is saying that I have a Soft 404 at this URL:

That is the Joomla template that is used on my website. When I go to that URL, it shows a blank page with the source: <html><body bgcolor="#FFFFFF"></body></html>

I asked the developer and they explained why it happened and said to just add that page to my robots.txt file to stop Google from crawling it.

I did it, but now Google won't crawl it at all when I Inspect it and Request Indexing- since it is blocked by robots.txt. It's been a couple weeks and it's still showing as a Soft 404, so it seems as if it will stay that way.

What can I do?


So I removed it from robots.txt and I added that tag to the HTML page.

Now Search Console is still saying that it is a Soft 404 but that the URL is unavailable to Google. So it seems as if I am stuck int he same vicious cycle of it being labelled a Soft 404 but it not being able to crawl it to see that it is not.

Would it be better to add an on-page redirect to the homepage?
From Block search indexing with 'noindex' - Search Console Help
Block search indexing with 'noindex'
You can prevent a page from appearing in Google Search by including a noindex meta tag in the page's HTML code, or by returning a 'noindex' header in the HTTP request. When Googlebot next crawls that page and sees the tag or header, Googlebot will drop that page entirely from Google Search results, regardless of whether other sites link to it.
It may take a while but that soft 404 will disappear. Just leave it and be patient.

Login / Register

Already a member?   LOG IN
Not a member yet?   REGISTER

LocalU Event

LocalU - Sold Out

  Promoted Posts

New advertising option: A review of your product or service posted by a Sterling Sky employee. This will also be shared on the Sterling Sky & LSF Twitter accounts, our Facebook group, LinkedIn, and both newsletters. More...
Top Bottom