Tim Colling

Moderator
Local Search Expert
LocalU Member
Joined
Sep 3, 2014
Messages
1,292
Reaction score
713
I have seen a number of cases lately where social media icons are turning up on GMB profiles - you can see this in a number of profiles and it's been reported on here on the Forum at least once in the past month or so. However, I haven't been able to provoke them to appear on any of the GMB profiles that I manage.

So what's the "recipe" to get them to work?

It used to be that you needed to use well-written schema code on the website that included the social media URLs using the "sameAs" property in the Organization or localBusiness schema types. That worked for me and my clients, years ago. Then eventually, Google made them all disappear.

I still have well-formed schema code on my websites that includes that same information as before. Still not seeing the icons, and yet, I see that they appear for other businesses in the same primary category with the same schema notation.

So what is the "recipe"? For once, I don't think "it's in the Guide". I looked.

Thanks!
 

Rich Owings

Local Search Expert
LocalU Member
Joined
Apr 21, 2014
Messages
752
Reaction score
541
Do you link to them from the website? If so, I don't know what else you can do other than use sameAs schema and wait.
 

Ellen

Member
Joined
Apr 4, 2016
Messages
44
Reaction score
17
@Tim Colling have you discovered anything new on this topic? I have some businesses that are just stuck with a lone Twitter icon.

2019-12-02_0558.png
 

Login / Register

Already a member?   LOG IN
Not a member yet?   REGISTER

Most UpVoted Answers

LocalU

  Promoted Posts

New advertising option: A review of your product or service posted by a Sterling Sky employee. This will also be shared on the Sterling Sky & LSF Twitter accounts, our Facebook group, LinkedIn, and both newsletters. More...
Google Product Exert


Top Bottom